• Welcome to ZD Forums! You must create an account and log in to see and participate in the Shoutbox chat on this main index page.

Game Help Inability to Enter Buildings: Minish Cap

In my copy of the Minish Cap, It won't allow me to enter buildings. I'll walk up to a door and it acts like there's a wall there. Maybe 5% of the time, it actually lets me go through. It's getting really annoying and I'd like to know if anyone has had a similar problem or knows if there's a way to fix it.


Mad haters lmao
May 26, 2010
Hylian Champion
Some doors are actually just graphics; there is no entrance to a few of them. TMC also has a neato glitch that lets you pass through buildings and other collision-based barriers; I forgot how to activate it, but a soft reset (or hard reset) typically does the trick from what I remember 4 years ago.
No, I know I can go the ones I'm talking about can be accessed, as A. I've been in them before and 2. I've seen people online do it before. One I particularly have trouble with is the shop in Hyrule Castle Town with the Green Rupee on top, Which I know can be entered.
A or R don't work either, I tried.
I tried soft resetting 3 times. Still doesn't work.

One thing I did notice however, was that the cartridge I got had the two plastic parts that held the cartridge together broken on one side and if you didn't have it in the Gameboy just right it wouldn't read the cartridge.
Last edited:
Jul 14, 2023
This is an old thread, but just commenting to let people know I experienced the same bug, I’ve 100% every heart piece, kinstone, and figure and all doors in hyrule town are unable to be opened for me on my official cart. Openings like the inn and figure shop are able to be walked in, but doors like the item shop don’t do anything for some reason

Users who are viewing this thread

Top Bottom